Zum Inhalt

Eclipse: Proxy Authentication Required

…Oder der Proxy-Spass mit Eclipse

Die Ausgangslage:
  • aktuelle Eclipse Version  (Neon)
  • JRE 1.8.0_92x32 bit
  • die Proxy Einstellungen sind korrekt gesetzt, inkl. Authentication Params.
  • Eclipse Marketplace lässt sich in der IDE aufrufen
  • sobald man versucht ein PlugIn zu installieren, bekommt man diese Fehlermeldung

Eclipse Proxy Fehlermeldung

 

Die Lösung:

Für die Versionen bis 4.3 muss in der eclipse.ini folgender Paramter hinzugefügt werden

-Dorg.eclipse.ecf.provider.filetransfer.excludeContributors=org.eclipse.ecf.provider.filetransfer.httpclient

alternativ kann die IDE mit folgendem Aufruf gestartet werden

eclipse -vmargs -Dorg.eclipse.ecf.provider.filetransfer.excludeContributors=org.eclipse.ecf.provider.filetransfer.httpclient

Ab Version 4.3 wird eine neuere Version des http Clients verwendet, daher kommt in die eclipse.ini

-Dorg.eclipse.ecf.provider.filetransfer.excludeContributors=org.eclipse.ecf.provider.filetransfer.httpclient4

Und der alternative Startaufruf ändert sich zu

eclipse -vmargs -Dorg.eclipse.ecf.provider.filetransfer.excludeContributors=org.eclipse.ecf.provider.filetransfer.httpclient4

Die genauren Details welche Bibliothen warum Probleme macht können hier nachgelesen werden.

Eine verwandte Fehlermeldung unter Eclipse

WinHttp.GetProxyForUrl for pac failed with error 'Zugriff verweigert
' #5.

kann umgangen werden in dem der eclipse.ini der Parameter gesetzt wird:

-Djava.net.preferIPv4Stack=true

Published inEclipseIDEProgrammieren

Schreibe den ersten Kommentar

    Schreibe einen Kommentar

    Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

    Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.